Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

  • Best Of...
  • Groups
  • Thank you so much for your involvement with the Owner's Club Forum! We hope you've gotten some great information and had the chance to interact with other owners on the current system.

    We are going through a website transition, and some things might look a little different in the next few weeks. We are working on building out the system design to reflect the changes being made on our website. Please bare with us during the transition!

    Livewell issues with 2016 SS 211

    My SS 211 came with 2 livewells.  I only use the rear livewell and just recently, it started kicking the breaker after a few seconds of running.  My first question is where in the heck are the livewells located?  I believe I found the access to them from the rear ports near the motor.  I screwed the covers off and can see down into the bilge area and see where they leave the boat and can somewhat follow it back up from there and see 2 red objects that look like they could be the pumps.  I stretched as far as possible and could move the wires a little bit on them and I believe the pump ran longer than it did before kicking the breaker.

    If what I am seeing really is the livewell pumps, how is maintenance done on them?  I am 6'4" and have long arms and could barely reach back to them, no way could i do any real work on them.

    Is there another entrance that I am missing?

    Thanks in advance.

    David

    Comments

    • PescaBenePescaBene Lake Candlewood, CTMember Posts: 62 ✭✭
      I have an SS231. The red canisters are indeed the pumps.  The impeller is probably stuck and that’s why the breaker is tripping. You have to remove the pump from the housing and give it some help.  I know it’s hard to reach them.  I am able to reach mine from the stern hatch.  I thought about lifting the stern floor locker out but didn’t have to go that far.  
    Sign In or Register to comment.