Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

  • Best Of...
  • Groups
  • Thank you so much for your involvement with the Owner's Club Forum! We hope you've gotten some great information and had the chance to interact with other owners on the current system.

    We are going through a website transition, and some things might look a little different in the next few weeks. We are working on building out the system design to reflect the changes being made on our website. Please bare with us during the transition!

    Fuse issue? 2008 FD 211

    So my bilge pump quit and is scheduled to be replaced.
    However, I noticed 2 transom (battery switch area) 30 amp fuses.  Both were pretty cruddy.  I took each fuse out.

    Re seated them and then went to turn power on at Master and flipped on Livewell, Nav/Anch, Freshwater switches.  I get this buzzing/hum sound.  They do not function now.    The rocker switch lights work.  Even the dock lights dont work now.  The only thing that powers are the Courtesy lights and Stereo.

    When I removed and reseated the fuses, did I mess something up?    How do I clean the corrosion off the waterproof fuse casing and should I replace the fuse itself?

    Help....

    Thanks

    Comments

    • GRTomboyGRTomboy USAMember Posts: 5
      My master to the helm is a 25amp and I'm replacing the holder and the fuse both, due to corrosion and intermittent functioning of my dash gauges.  The other blade fuse back there is inline for the bilge, and then a big master fuse in a waterproof casing I think is 50amp, also to be swapped out.  Cheap and easy repair.
    Sign In or Register to comment.