Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

  • Best Of...
  • Groups
  • Thank you so much for your involvement with the Owner's Club Forum! We hope you've gotten some great information and had the chance to interact with other owners on the current system.

    We are going through a website transition, and some things might look a little different in the next few weeks. We are working on building out the system design to reflect the changes being made on our website. Please bare with us during the transition!

    Need Wiring Diagram for a 2003 Sundeck SD187. The Electircal Panel Has Limited Power

    pitaloripitalori Member Posts: 1
    I have an SD187 and the engine and the tilt work fine.  However, the power coming into the electrical panel is very weak.  If everything is turned off, the voltage reads nearly 12 volts.  However, as soon as I turn anything on, the voltage drops.  I can sometimes power the radio, but if you turn on any lights, the voltage drops down to nearly zero.  I am measuring the panel voltage relative to the battery ground.  I already checked the fuse holder that comes out of the dual battery switch.  This looked very corroded, but I measured the voltage just after the fuse and it read normal even with accessories turned on.  Prior to the power failing, the boat took on a lot of water and all of the wiring in the back of the boat got submerged (fresh water).  A few weeks after this happened is when the problems started occurring.  The fuse to the automatic bilge pump blew, which is what caused the boat to take on water.

    Comments

    • cjjjdeckcjjjdeck Northern NJMember, Moderator Posts: 1,256 ✭✭✭✭
      Welcome to the Owners Forum, pitalori!

      Definitely sounds like a poor connection at the main harness.  I had a similar sounding condition.  The dealer found I had a arcing problem at the main helm wiring harness connection in the back of the boat that needed to be replaced.

      I can get you the wiring diagrams for your boat.  I am sending you a Personal Message regarding it.  Look for a red number "1" next to the globe and envelope icons next to your Avatar in the upper left corner of the screen.  Click on the envelope, then click on my message to read it.
      2012 SD237 I/O Mercruiser 5.0L MPI ECT/ Bravo 3
      2012 Load Rite Elite Tandem axle trailer

    • caseynettlescaseynettles Jacksonville, FLMember Posts: 69 ✭✭
      I had a very similar situation shortly after I took ownership of my sd217....discovered the main inline barrel fuse assembly coming from the switch was corroded...replaced with a marine grade blade style fuse of the same amperage...I believe it was 10guage 30 amp....problem solved and the blade style IMO is much more robust and should last many times longer. PS....be sure to use water proof wire connectors with the heat shrink with sealant inside.
    Sign In or Register to comment.