Thank you so much for your involvement with the Owner's Club Forum! We hope you've gotten some great information and had the chance to interact with other owners on the current system.

2013 hurricane sundeck sport 188ob

I've been having an issue with my electronics working onboard my boat. The boat has dual batteries but of which are fine and in good working order. The engine will run and drive but nothing else comes on. I have checked all switches and connections and nothing is loose or missing. I've checked both relays under the console as well as the ignition relay wired into the battery compartment. I've tried to reset the ignition relay and I'm getting 8v to ground on one leg and nothing on the other leg. Any and all help would be greatly appreciated. Im at the point were I'm just going to replace all three components if no answer if found. Thanks again

Comments

  • psfrizzpsfrizz Member Posts: 11
    I had that same problem, I just changed the ignition relay by the battery.
  • cjjjdeckcjjjdeck Northern NJMember, Moderator Posts: 1,610 ✭✭✭✭
    Often these conditions can be caused by a bad/poor ground.  All the switches on the dash should have a common ground going to them.  Since the Master Switch doesn't seem to be working I would start in that location.
    2012 SD237 I/O Mercruiser 5.0L MPI ECT/ Bravo 3
    2012 Load Rite Elite Tandem axle trailer

  • 1pointofview1pointofview Member Posts: 74 ✭✭
    I had both master power relays go out on mine last year.  Not expensive and not too terribly hard to replace. Just have to note what wire goes to what post...


    2013 Hurricane SS188
    115 Yam
    Magic Tilt Trailer
    Hotty Toddy
  • bshar1986bshar1986 Member Posts: 4
    I did further troubleshooting and after replacing the 40amp thermal relay all power was restored.. Thanks for all your
Sign In or Register to comment.