Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

  • Best Of...
  • Groups
  • Thank you so much for your involvement with the Owner's Club Forum! We hope you've gotten some great information and had the chance to interact with other owners on the current system.

    We are going through a website transition, and some things might look a little different in the next few weeks. We are working on building out the system design to reflect the changes being made on our website. Please bare with us during the transition!

    Engine cuts out after low oil problem fixed

    jdewittjdewitt Member Posts: 0

    Ran 'er low on oil. (Merc. 225 EFI)  Refilled main reservoir partly, started up & sucked up into engine reservoir.  Topped that off and filled main reservoir to very top.  Took 'er back out and she purred like a kitten until I got over about 2000 RPM's.  What to do?

    Comments

    • 89checkmate89checkmate Member Posts: 148 ✭✭✭
      edited August 2014

      Did you have the caps on the main oil tank tight and loosen the small cap on the engine tank when you started it and let the engine tank fill?

      It's a pressurized system so oil is pushed in the small tank as air is let out the cap on the top, sounds like air in the system, suck the top inch or two of oil out of the tank on the engine with a syringe or turkey bastor and try doing it that way, let it fill until oil starts to come out the top of the small tank and then tighten cap, have a rag handy, hope this helps.

    Sign In or Register to comment.