Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

  • Best Of...
  • Groups
  • Thank you so much for your involvement with the Owner's Club Forum! We hope you've gotten some great information and had the chance to interact with other owners on the current system.

    We are excited to announce that a full Forum system upgrade is under way, which will make it even easier to get answers to your questions, help other owners by using your boating experience, and receive dependable advice from our network of experts. While things may look and operate a little differently, we believe the new system will ultimately improve your Forum Member experience.

    We are doing everything we can to transition your account smoothly without you having to change your current login, username or password. You should be able to get into your account exactly the same way once the transition takes place. However, if you have any questions or comments, please leave a comment in the General Discussions category.

    We look forward to sharing new features with you as we upgrade and improve your Owner's Club Forum experience!

    Can't trim my boat

    Thorne48Thorne48 Member Posts: 1

    Just purchased a 2010 Hurricane sundeck used, with a Mercury 200 verado, when I take off the boat comes up too plane with no problem, bit I can not adjust my trim, the display trim position shows 0, also the gauge on the dash shows down,  just sold my stern drive, never had a problem with trim. I never owned an outboard, wondering if these Mercury outboards trim differently. 

    Answers

    • cjjjdeckcjjjdeck Northern NJMember, Moderator Posts: 1,254 ✭✭✭✭

      The motor should absolutely be able to trim.  Does the switch on the motor tilt it when you are at standstill?  If it does and the trim switch by the helm doesn't, then you may have a bad or disconnected helm switch.

      2012 SD237 I/O Mercruiser 5.0L MPI ECT/ Bravo 3
      2012 Load Rite Elite Tandem axle trailer

    • 89checkmate89checkmate Member Posts: 148 ✭✭✭

      Like cjjjdeck said does it work at a stand still? If it won't go up under a load check your oil in the trim pump for water or if it's low, most likely have a seal leaking, check for oil around the trim rams, it doesn't take much of a leak to lose pressure under a load.

    • jt3kidsjt3kids Member Posts: 15

      I have a 2004 fundeck 201.  trim pump solenoids both burnt up.  fried the connectors. 
    Sign In or Register to comment.