Thank you so much for your involvement with the Owner's Club Forum! We hope you've gotten some great information and had the chance to interact with other owners on the current system.

Master switch not working

levmaclevmac Member Posts: 11
Ok. I will try to make this short as I can. Spent day on my new 2013 211 pulling kids on tube ect listening radio ect ect Parked on sand bar couple hours. Get back in head home. No power to radio bilge lights fresh water horn ect. No engine starting problems or tilt trim issues. Get to dock dark now and can see that master switch has faint glow of orange power but quickly goes out if I hit any other switch such as horn fresh water stereo First question is why is this going on. Seems like it has power just not too much so should not be a fuse blown Boat has about 50 hrs. Second if it rains tonight will my bilge kick on without power to dash??

Comments

  • cjjjdeckcjjjdeck Northern NJMember, Moderator Posts: 1,610 ✭✭✭✭
    I had a similar problem with my boat not long after I purchased it.  The dealer found the main wire harness connector coming from the helm and located in the engine compartment failed and had to be replaced.

    You may also have a grounding problem (not uncommon for boats).

    The bilge pump should have been installed with a direct connection to your battery.  The helm switch only turns the pump on manually and bypasses the direct connection.  If you want to be sure, pour water into the bilge area until the pump turns on (usually a couple of inches or so).
    2012 SD237 I/O Mercruiser 5.0L MPI ECT/ Bravo 3
    2012 Load Rite Elite Tandem axle trailer

Sign In or Register to comment.